Tags: appeared, bloody, clumps, drugs, green, health, infection, kidney, medications, mucus, opening, pain, symptoms, system, urethra, urethral, urinary, urine

Green mucus, bloody clumps in urine coming from urethral opening infection?

On Health & Drugs & Medications » Kidney & Urinary System

2,515 words with 1 Comments; publish: Tue, 18 Dec 2007 22:54:00 GMT; (900109.38, « »)

New symptoms have appeared and now I have bloody clumps (with pain when it comes out of my urethra opening) and green mucus that I KNOW is not from my vagina. I feel this burning pain on the outside of my urethra opening after this happens and I have constant flank pains still. I do get chills off and on and I do feel feverish off and on. The blood and the green mucus doesn't happen all the time it's mainly just the green mucus that I see when I wipe. I was thought to have kidney stones (from an x-ray there was something in there that was 5cm) but when they did CT scan no stones showed up. I also did not have a UTI but have the classic symptoms of burning when urinating, urgency, and my urine does not smell like urine it smells odd. My urine is also still cloudy and dark yellow orange in color.

Don't think this has anything to do with whats happening now but I do have fatty liver, gallstones, and an ovarian cyst. Have not menstrated in 5-6 months now and I do not have a UTI, or any STD's. Abnormal labs: high RBC, high liver enzymes, 1 pt low protein, blood in urine, ketones in urine, high glucose (im type 2 diabetic).

I know green mucus means infection but why the blood clumps and green mucus? Could it be that I did have a kidney stone and it might be lodged somewhere? Please help :\

All Comments

Leave a comment...

  • 1 Comments
    • The urine is still that orangish or dark yellow color but I do kinda see swirls of blood in the urine but it's not that I am straight peeing blood but I can visibly see blood in my urine (this has been going on off and on though).

      I know that you told some girl on here that the green mucus is sign of an infection so that is why I believe I have one but don't know where and what of since I am still testing negative for a UTI.

      The odd thing is on the x-ray it showed a stone in my left kidney, the ct scan showed nothing but if the stone they saw on the x-ray was 5mm then I'm sure they'd be able to see it on the ct scan they did. Unless it traveled and is blocked somewhere now. Is there a surefire way to know if I had kidney stones? I mean is there a blood test? One last thing I did forget to mention, they did find protein in my urine last time they checked (new to me), but no blood that time (I was not having the pain that day in my urethra area). I've never had a kidney function test so I think I might request this when I go in next (friday is earliest I MIGHT be seen). Thanks Allie for your help!

      #1; Tue, 18 Dec 2007 21:13:00 GMT